OpenVpn Network-Manager DNS Problem?

OpenVpn Network-Manager DNS Problem?

Hallo,

ich hatte das Problem sobald ich mit dem Network-Manager eine Verbindung über OpenVPN aufbauen wollte das keine DNS-Querys mehr gingen. Nach ein bisschen Fehler Analyse bin ich auf den dnsmasq Dienst gestoßen.

Dieser war auch mein Problem. Aber eigentlich sollte ich ja über DHCP einen Nameserver zugeteilt bekommen. Jedoch wurde dies durch diesen Dienst nicht mehr gemacht.

Also habe ich in folgender Datei „/etc/NetworkManager/NetworkManager.conf“ folgende Zeile im Bereich Main auskommentiert „dns=dnsmasq“. Nun noch Network-Manager neu starten und ziehe da es geht.

Update auf Windows 10

Hallo und Willkommen zu meiner Erfahrung mit Windows 10,

Heute hat sich mein Windows 8 selbstständig auf Windows 10  Update ab wohl ich es nicht bestätigt habe.

Windows 10 Update

Windows 10 Update

Das Upgrade hat ca 1 Stunde gedauert der Rechner Startet mehrmalig neu.
Also erste geh versuche auf Windows 10 kommen später noch hinzu zum Beitrag:

Proftpd Plesk 12.0 & 12.5

Hallo,

Plesk 12.0 und Plesk 12.5 haben mit Proftpd in Verbindung mit dem Atomicorp Repository ein kleines Problem.

Jan 19 00:07:28 web01 proftpd[11217]: fatal: ScoreboardFile: : unable to use '/var/run/proftpd/scoreboard': No such file or directory on line 74 of '/etc/proftpd.conf'

Es gibt Zwei Lösungswege von Plesk:
1. Starte den Updater über die CMD
/usr/local/psa/admin/bin/autoinstaller
2. Kommentiere die Zeile 74 einfach aus 🙂
nano -wc /etc/proftpd.conf
Zeile 74 und auskommentieren

service xinetd restart

GZIP Komprimierung Plesk

GZIP Komprimierung Plesk

Hallo Liebe Blog-Leser,

heute geht es um GZIP Komprimierung in Plesk.
Ihr Loggt euch in eurer Plesk ein und Wählt die Entsprechende Domain aus dann geht Ihr auf Einstellungen für Apache (Httpd) und Ngnix.

Wenn ihr Apache Nutzt fügt Ihr bei http und https folgendes ein:


AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript
AddOutputFilterByType DEFLATE application/x-shockwave-flash

 

und bei Ngnix folgendes:


gzip on;
gzip_disable "MSIE [1-6]\.(?!.*SV1)";
gzip_proxied any;
gzip_types text/plain text/css application/x-javascript
text/javascript application/javascript text/xml application/xml
application/xml+rss text/javascript image/x-icon image/bmp
image/svg+xml;
gzip_vary on;

Jetzt sollte die GZIP Komprimierung funktionieren.

 

Achtung : Bei nutzung mit Ngnix es nur bei Ngnix einfügen 😉

Betreff in Exim mit filter Regeln

Hallo,

Ich befasse mich seit knapp über ein Jahr mit EXIM und habe einige Sachen gelesen wie man den Betreff um schreiben kann ich Persönlich fande die Lösungen nicht  so sauber das man Sie gut Administrieren kann. Es wurde mit Perl scripten bzw bash Scripten Gelöst ich frage mich nur warum ? Okay heute Gibt es von mir eine kleines Example 🙂

Als erstes legen wir uns im exim Ordner eine subject_filter.conf an. Diese füllen wir mit folgenden inhalt.

if "${if def:header_X-New-Subject: {there}}" is there
then
headers remove Subject
headers add "Subject: $h_X-New-Subject:"
headers remove X-New-Subject
endif

Dann sagen wir Exim das er noch eine Systemfilter Brauchen. Wir fügen folgende Zeile ein.

system_filter=/etc/exim/filter.conf

Als Nächtes sagen wir noch welchen Betreff er Umschreiben soll. Das machen wir Folgendermaßen

message = X-New-Subject: [SPAM($spam_score)] $h_subject

Im oben genannten Beispiel geben wir den SpamScore in Betreff mit an.

Quagga CentOS6

Hallo Liebe Blog Leser,

heute erkläre ich euch Setup einses Quagga BGP Router auf einem CentOS6.

Zuerst Installieren wir uns ein CentOS6 dann machen wir erstmal ein yum upgrade um alle alten Pakete zu aktualisieren.

Nach dem Upgrade ein kurzer reboot um den Neusten Kernel zu Laden.

Okay nun installieren wir  Quagga mit yum install quagga okay qugga ist nun fertig installiert jetzt haben wir noch ein Problem mit SELinux  einfach die anwendung quagga freigeben.

Mit : setsebool -P zebra_write_config 1

Nun  müssen wir noch ein paar Dienste Starten.

service zebra start
chkconfig zebra on
service bgpd start
chkconfig bgpd on
(chkconfig bedeutet mache autostart an)

Nun laufen unsere Dienste also Logen wir uns in die CLI ein mit vtysh.

Gehen wir Davon aus das auf eth0 die Verbindung zum Peering bzw Transit Partner besteht konfiguieren wir uns die entsprechende IP auf das Interface im normal fall wird hierfür ein /30 verwendet.

In meinem Beispiel folgendes netz 192.168.10.8/30
Unser Peering bzw Transit Partner nimmt folgende IP Addresse : 192.168.10.9/30

Wir nehmen in unserem Router die 192.168.10.10/30

Dann Konfigurieren wir mal unser Interfacw eth0 über die CLI.

Okay wir gehen wir folgt vor:

conf t
int eth0
description „Beschreinbung zum Peering Partner“
ip address 192.168.10.10/30
exit
exit
wri mem (Weil sonst config nur im ram läuft und nach dem nächsten reboot wegen ist)

Nun sollten wir mit ping 192.168.10.9 unsere gegenstelle erreichen. Kommt eine Antwort ? Okay alles richtig gemacht. Als nächstes Konfigurieren wir unsren Router. Das machen wir wie Folgt:

conf t
router bgp 12345
bgp router-id 192.168.10.10
neighbor 192.168.10.9 remote-as 54321
neighbor 192.168.10.9 description „Zum beispiel name des Peering Partner“
exit
exit
wri mem

Sollte unserer Peering partner uns netze weitergeben können wir die Folgender maßen einsehen.
show ip bgp neighbors 192.168.10.9 routes
und mit show  ip bgp  neighbors  192.168.10.9 advertised-routes sehen wir welche networks wir ihn übermitteln. Aktuell sollten wir keine sehen weil wir noch keine networks eingerichtet haben.

Dann wollen wir mal networks einrichten. Unsere Router Soll für Folgende Netzwerke zuständig sein :

192.168.1.0/24
192.168.2.0/24
192.168.3.0/24

Achtung laut BGP richtlienen muss mindestens ein /24 advertised werden.

Wir gehen wie folgt vor :
conf t
router bgp 12345
network 192.168.1.0/24
network 192.168.2.0/24
network 192.168.3.0/24
exit
exit
nun schauen wir ob es geklappt hat:

show  ip bgp  neighbors  192.168.10.9 advertised-routes
BGP table version is 0, local router ID is 192.168.10.10
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale, R Removed
Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path
*> 192.168.1.0/24    192.168.10.10         0         32768 i
*> 192.168.2.0/24  192.168.10.10           0         32768 i
*> 192.168.3.0/24 192.168.10.10           0         32768 i

Total number of prefixes 3

okay nun machen wir nur noch wri mem.

Das war es eigentlich schon im Groben und Ganzen gern könnt ihr mir ein Kommentar da lassen falls Fragen sind.